name_untitledのエッセイ

IT関係で知ったことなどを記事としてあげていきます。内容に不備や質問などあればぜひコメントをよせてください。

Androidのサンプルプロジェクトで、Gradle version 2.2 is required. Current version is 2.10っていう感じのエラー。無駄にはまった。

stackoverflow.com

AndroidのサンプルプロジェクトをGitHubから落として、開いたらこんなエラー。BuildToolsのバージョンとかを書き換えればいいと思ってたかをくくってたら、なかなか解決しなかった。

原因は、サンプルプロジェクトは複数のアプリを含んだやつで、プロジェクトレベルの設定を読んでバージョン違うとメッセージが出てたのに、アプリレベルのbuild.gradleを一生懸命修正してた、、、。

1階層上のbuild.gradleを修正して、開き直してOK。